IST  

Platform Availability


This page gives details of the availability of the latest versions of X-Designer. For details regarding the previous X-Designer versions and earlier releases of Operating Systems see the early platforms page.

The Operating System version shown is that against which X-Designer was built. Normally it will happily run on a later version. See the notes at the end for details of compatibility with other OS versions, and the situation regarding future support for a particular platform.

We are continually reviewing the number of platforms for which X-Designer is available. If your platform is not shown in the following list please contact us by using our enquiry form or otherwise.

X-Designer Release 9.0
requires a Motif 2.1 environment and is currently available for the following platforms. The platform shown is the one it was built on. It is a 32-bit application but will run, and has been tested, on 64-bit systems.

In addition to SuSE 10.3 (32-bit) the Linux version has been tested on Ubuntu 9.04 (Linux 2.6.24) (32-bit) and is known to run on OpenSuSE 11.1 (Linux 2.6.27) (64-bit) and Kubuntu 9.04 (32 & 64-bit). It will almost certainly run on other versions of Linux incorporating version 2.6.22 or later of the kernel, but these have not yet been formally verified.

  • SuSE 10.3 (Linux 2.6.22)
  • Sun SPARCstation running Solaris 10 (SunOS 5.10)
  • Intel x86 running Solaris 10

X-Designer Release 8.1
requires a Motif 2.1 environment and is currently available for the following platforms. The platform shown is the one it was built on. It is a 32-bit application but will run, and has been tested, on 64-bit systems.

It is known to run on SUSE 9.2 & 10, Redhat 9, Redhat Enterprise 4EL and Fedora Core 6 & 9. It will almost certainly run on other versions of Linux incorporating version 2.6.5 or later of the kernel, such as Redhat Enterprise 5EL, Debian 4 and Ubuntu 8, but these have not been formally verified.

  • SuSE 9.2 (Linux 2.6.5)

X-Designer Release 8.0
requires a Motif 2 environment and is currently available for the following platform. The platform shown is the one it was built on - generally X-Designer will run on a higher version number of the Operating System. It has been verified on Solaris 8, 9 and 10.

  • Sun SPARCstation running Solaris 8 (SunOS 5.8)

X-Designer Release 7.1
requires a Motif 2 environment and is currently available for the following platforms. The platform shown is the one it was built on - generally X-Designer will run on a higher version number of the Operating System.

  • Sun SPARCstation running Solaris 7 (SunOS 5.7)
  • HP 700/800 (PA-RISC) running HP-UX 11.00
  • Silicon Graphics running Irix System V Release 6.5
  • IBM Risc System/6000 running AIX 4.3
  • Intel x86 running Solaris 7
  • Intel x86 running FreeBSD 4.2
  • Intel x86 running RedHat 6.1 (Linux 2.2.12-20, libc6)
  • Intel x86 running RedHat 7.3 (Linux 2.4.18-3, libc6)
  • Intel x86 running RedHat 9 (Linux 2.4.20-18.9, libc6)

Previous X-Designer versions
For details about previous X-Designer versions and earlier releases of Operating Systems see the early platforms page.


Notes

The Operating System version shown above is that against which X-Designer was built.

X-Designer is generally not sensitive to the point release of the Operating System. It will generally also run under a higher version than specified, but it is probable that there will be problems when trying to run it under a lower version.

Sun
X-Designer 9 requires Solaris 10, or later, and its Motif 2 environment.

X-Designer 8 requires Solaris 8, or later, and its Motif 2 environment. It has been tested on Solaris 8, 9 and 10.

X-Designer 7 requires Solaris 7, or later, and its Motif 2 environment. It has been tested on Solaris 7, 8, 9 and 10.

There are actually two versions of X-Designer 5.5 for SPARC Solaris. The SPARC Solaris 2.5.1 version was built and tested with Solaris 2.5.1, and also tested with Solaris 2.6, Solaris 7, 8 and 9. The SPARC Solaris 7 version was built and tested with Solaris 7, and also tested with Solaris 8 and 9. You should use the Solaris 2.5.1 version unless you are intending to integrate Motif 2 widgets into X-Designer, in which case you should use X-Designer 7.

Silicon Graphics
X-Designer 7 requires IRIX 6.5 and its Motif 2 environment.

There are actually two versions of X-Designer 5.5 for Silicon Graphics machines. One built on Irix 6.2 and one on 6.5.

All versions were built with X11R6 and thus work best with an X11R6 environment.

HP-UX
X-Designer 7 was built on a HP B132 (PA-RISC) using HP-UX 11.00 and X11R6. This has been tested on a machine running HP-UX 11.11 (also known as HP-UX 11i). Note that it will not run on HP-UX 11i for the Itanium Platform.

X-Designer 5 was built on a HP B132 using HP-UX 10.20 and X11R6. This has been tested on an machine running HP-UX 11.

IBM
X-Designer 7 requires AIX 4.3 and its Motif 2 environment. It is known to run on AIX 5.

There are two versions of X-Designer 5.5 for the IBM Risc System/6000, one built on AIX 4.2 and one on 4.3. You should ensure that you have the correct version as it is known that they will not run properly on other versions of AIX, although the AIX 4.3 version is known to run on AIX 5.

HP Compaq Tru64 UNIX
X-Designer 5.5 was built and tested on Compaq Alpha running Tru64 UNIX 4.0, and also tested on Tru64 UNIX 5.1

Linux
X-Designer 9 for Linux running on the Intel x86 platform was built using the Open SuSE 10.3 distribution containing Linux 2.6.22. It is a 32-bit application which runs, and has been tested, on 64-bit Linux systems. In addition to SuSE 10.3 (32-bit) it has been tested on Ubuntu 9.04 (Linux 2.6.24) (32-bit) and is known to run on OpenSuSE 11.1 (Linux 2.6.27) (64-bit) and Kubuntu 9.04 (32 & 64-bit). It will almost certainly run on other versions of Linux incorporating version 2.6.22 or later of the kernel, but these have not yet been verified.

X-Designer 8 for Linux running on the Intel x86 platform was built using the SuSE 9.2 distribution containing Linux 2.6.5. It is a 32-bit application but will run, and has been tested, on 64-bit Linux systems. It is known to run on SUSE 9.2 & 10, Redhat 9, Redhat Enterprise 4EL and Fedora Core 6 & 9. It will almost certainly run on other versions of Linux incorporating version 2.6.5 or later of the kernel, such as Redhat Enterprise 5EL, Debian 4 and Ubuntu 8.

There are two versions of X-Designer 7.1.8 for Linux running on the Intel x86 platform - one was built using the RedHat 7.3 distribution containing Linux 2.4.18-27 and the other on RedHat 9 containing Linux 2.4.20-8. You should use the most appropriate version. Please note it is known that there are problems running on RedHat 8 and we would recommend that you do not use RedHat 8.

X-Designer 5.5 for Linux running on the Intel x86 platform was built using the RedHat 6.1 distribution containing Linux 2.2.12-20 and glibc (libc6). There is also a version of X-Designer 7.1 built on RedHat 6.1. These should run on most Linux systems that use glibc (libc6). They have been tested on RedHat 6.1, 7.1, 7.2, and 7.3.

Note that if you are using X-Designer 5.5 on a Linux 2.4 kernel (e.g. RedHat 7.1) you will need an upgrade to the licensing software. This is included with X-Designer 7 and there is a special link on the X-Designer 5.5 download page.

Please note that X-Designer is built and verified with the officially supported OpenMotif (version 2.1). You will need to have installed this (free) package first - see the Motif download page. X-Designer is not compatible with OpenMotif 2.2 or 2.3 which is installed by default on some recent Linux distributions. See the relevant MotifDeveloper page for more information.

FreeBSD
Please note that X-Designer is built and verified with the official OpenMotif (version 2.1). You will need to have installed this (free) package first - see the Motif download page.

Compaq (DEC) Alpha VMS
The latest version of X-Designer for Compaq Alpha running OpenVMS is 4.6. See the early platforms page.
Future Versions

We make no guarantee that the latest version of X-Designer will be ported to all platforms. Availability is largely driven by customer demand, so if X-Designer is not shown as available for your platform then please contact us by using our enquiry form or otherwise.

At this point in time there is no further development planned for the following:

  • Any platform without a Motif 2.1 environment
  • Any other platform without an existing release of X-Designer 7 or higher
  • Any Operating System version lower than that used to build the latest release of X-Designer
  • Compaq (DEC) Alpha OpenVMS
  • Any Japanese versions

If any of this gives you a problem please contact us by using our enquiry form or otherwise.

 

Top of Page COPYRIGHT ©1995-2017 IST Reading Ltd. ALL RIGHTS RESERVED Legal Info | Privacy | Contact Us